What is Dell System Update (DSU)

Dell System Update (DSU) ensures that the Dell systems are up-to-date with the latest BIOS, firmware, and software. DSU contains

Dell System Update User Guide can be found here

What is new in this release (Version : 16.05.00)

This release of Dell System Update (DSU) supports the following new features and operating systems: Known Issues: Note: The OMSA upgrade using DSU utility is temporarily disabled. To upgrade OMSA directly using yum, use the instructions in this page (Here)

The DSU distributes:.

Command Difference between Dell Linux Repository and Dell System Update

Dell Linux Repository Commands Dell System Update Commands
Setting Up Repository
1) wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
2) yum install dell_ft_install
3) yum install $(bootstrap_firmware)

1) wget -q -O - http://linux.dell.com/repo/hardware/dsu/bootstrap.cgi | bash
2) yum install dell-system-update
Inventorying Firmware

dsu --inventory
Updating Firmware


Advantage of DSU over Dell Linux Repository

Dell Linux Repository Dell System Update
1) Selected installation of updates is not possible from CLI 1) Selected installation of updates are possible from CLI
2) Cluttered console view 2) Better customer experience with specific readable information on the console
3) No option to revert to the earlier version 3) Reverting to earlier version of the update is possible, if repository have earlier version
4) Packages are based on Open Build System 4) Packages are based on Dell Update Packages (DUPs)

Supported Operating Systems

Note: "rebuilt" versions of the above such as CentOS or ScientificLinux and community distros like Fedora and OpenSUSE are not tested with this repository.

Setup The repository

#wget -q -O - bootstrap.cgi | bash

Installing DSU

Red Hat Enterprise Linux Servers

#yum install dell-system-update

SUSE Linux Enterprise Servers

#zypper install dell-system-update

Updating Firmware

The below command will provide a command line interface to update firmware


DSU utility version

dsu --version or dsu -v

Displaying the DSU utility version.

Getting System Inventory

#dsu --inventory

    To see the System Inventory

Category based installation

DSU allows category based device updates

Listing supported categories

#dsu --get-categories

    Gets the supported category values

Getting specific category updates

#dsu --category=<CATEGORY1,CATEGORY2,...>

    List only those updates belonging to categories

Non-interactive device updates

#dsu --non-interactive

    DSU supports devices updates in a non-interactive way where all the updatable components will be selected automatically and apply those updates without user intervention.

Getting the Upgradable updates only

dsu --apply-upgrades-only or dsu -u

    To get the list of only upgradable components

Getting the Downgradable updates only

dsu --apply-downgrades-only or dsu -d

    To get the list of only downgradable components

Getting the Equivalent updates only

dsu --apply-equivalent-updates or dsu -e

    To get the list of only equivalent components

Applying the updates specified in the file list

dsu --update-list=<FILENAME1,FILENAME2,...> or dsu -l

    To apply the updates specified in the file list, if available in configured repository.

Install OMSA

To install OMSA using this repository, use the following commands:

Red Hat Enterprise Linux Servers

#yum install srvadmin-all

SUSE Linux Enterprise Servers

#zypper install srvadmin-all

OMSA services should be manually started after installing/upgrading OMSA using DSU repository

Upgrade OMSA

To upgrade OMSA using this repository, where an OMSA version is already installed in the system, use the following commands.

Red Hat Enterprise Linux Servers

#yum --disablerepo=* --enablerepo=dell-system-update_dependent upgrade

SUSE Linux Enterprise Servers

#zypper mr -da; zypper mr -e "dell-system-update_dependent" ; zypper update; zypper mr -ea;

Note:-To update from local repository (custom), use the OMSA repository name instead of dell-system-update_dependent in the commands.
          In case of zypper upgrade, if there are repositories disabled by you, this command sequence will enable the repositories. You have to disable the repositories again manually.

Other supporting documents and links

In addition to this guide, you can access the following guides available at dell.com/support/manuals.

To get the complete list of options of DSU, use #dsu --help


A good place for support for this repository is the linux-poweredge mailing list.

File list

Use the following links to browse the contents of the repository

OS independent
OS dependent