Repository/FAQ

From DellLinuxWiki

< Repository
Revision as of 05:19, 8 November 2013 by Rathish das (Talk | contribs)
Jump to: navigation, search

This page is for frequently asked questions and common troubleshooting tips for the Dell repositories. For more information about the Dell Linux repositories, go to the main repository start page.

Contents

Troubleshooting

Repository setup fine, srvadmin wont install

  • OMSA (srvadmin) is only available in the hardware repository, so please ensure that you are setting up the hardware repository
  • OMSA is only available for certain Linux distributions. As of July 2011, OMSA is available for RHEL 5, RHEL 6, SLES 10 and SLES 11. If you are trying to install for an older OS that used to be supported, that may be possible, see Setting up older releases. If you are running one of the "recompiled" enterprise distributions, such as Centos or Scientific Linux, the repository should "just work".
  • OMSA is only available for certain Dell PowerEdge server models. Notably, "SC"-class systems do not have OMSA available. To check to see if OMSA is available on your system, use the "getSystemId' executable to look up your "System ID". Then go to the repository to see if there is a "system_ven_0x1028_dev_YOUR_SYSID" directory (substitute your system id as appropriate).
  • CENTOS: Ensure you have enabled plugins. You should see "plugins=1" somewhere in your yum.conf.
  • CENTOS: "J. Epperson" on Linux-PowerEdge mailing list says, "does the distroverpkg listed in yum.conf actually exist on the problem machines? I recently discovered a couple of my Centos boxes that somehow had ended up with distroverpkg=redhat-release instead of distroverpkg=centos-release."
  • Yum-based systems: In some circumstances, yum caches incorrect repository metadata. Run "yum clean all" to remove stale metadata, and retry.
  • Up2date can also cache incorrect metadata at times. To remove stale metadata, run "rm -f /var/spool/up2date/*" You should be able to safely remove all the files under /var/spool/up2date/ at any time and up2date will automatically download what it needs.
  • If you still have problems, please report to the linux-poweredge@dell.com mailing list. Please be sure to include the following information:
    • Subject line should mention the repository you are having problems with
    • Linux Distribution, arch, version, and patchlevel: eg. RHEL 5 i386 Update 6, or CentOS 5.4 x86_64.
    • Dell system model and system id. (use the "getSystemId" executable.
    • error output from any commands.
    • mention that you read this FAQ for 20% off your next lists.us.dell.com mailing list subscription. :)

Repository setup fine, srvadmin installed but wont start or I cannot get to it

  • have you started the services? Use the srvadmin-services.sh script to start them:
# srvadmin-services.sh start
  • If you get a message like:
 Starting ipmi driver:  [FAILED]

Then you need to make sure that the openipmi service is enabled and started:

# chkconfig openipmi on
# service ipmi start

SUSE10

  • If you get an dependency error while running "rug install dell_ft_install" command
    • Check rpm-python and python-xml packages are installed on system. You can install these packages from OS DVD.
  • When I execute "rug install " command, I get an error "Please insert media [Failed to mount cd:///?devices...."
    • If you have installed OS with the DVD, DVD is still listed as Package-Source in the Repository. You can just deactivate the DVD Repository:In YaST => Software => Software Repositories,uncheck the Checkbox "Enabled" on the Repository "openSUSE-DVD". Or you can remove DVD Repository with "rug sd 1 " command.
  • When I execute wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash" command, I get an error "can not find service 'dell-omsa-hwindep' and 'dell-omsa-hw'" or "ERROR: 'yum-dellsysid' is not available.'
    • Please ignore above error message and continue installation.
  • After doing rug update from OMSA7.3, I am seeing that OMSA connection service is not started.
    • Please execute "rug install srvadmin-webserver"
  • While doing rug install I am getting the error "xargs: rug: terminated by signal 6"

SUSE11

  • When I execute "zypper install " command, I get an error "Empty destinanation in URI: hd:///install/?device=....."
    • If you have installed OS with the DVD, DVD is still listed as Package-Source in the Repository. You can just deactivate the DVD Repository:In YaST => Software => Software Repositories,uncheck the Checkbox "Enabled" on the Repository "openSUSE-DVD". Or you can remove DVD Repository with "zypper sd 1 " command.
  • When I execute "zypper update" command, existing OMSA version not getting changed after upgrading and get a message "The following package updates will NOT be installed:"
    • Please ignore this message and upgrade OMSA by executing "zypper update srvadmin-all"
  • When I execute "zypper install <some_package>", get a message "The following package is not supported by its vendor", but installation goes smoothly.
    • Please ignore this message.

RHEL 3/4 + yum

The official RHEL 3 and RHEL 4 distributions do not have yum available, but you can install it separately from several third-party repositories. All of the Dell software repositories should work ok with yum in this way. Common problems/solutions:

  • Ensure that you have the miniumum yum version: yum 2.4.x or higher is required. You can manually hack the config file to make it work with earlier versions. See Making the repository work with ancient yum versions.
  • Ensure that plugins are enabled. Versions of yum less than 3.0 come with plugins disabled by default.

rsync

The yum repository contains .htaccess files. To enable your apache server to recognize these, you must allow overrides for the directory that contains the yum repository. For example, in your /etc/httpd/conf/httpd.conf file, under the <Directory "/var/www/html/yum_repository"> section you would have:

   AllowOverride All

Known Issues

  • YUM 7.3.1 :BMC firmware is missing in YUM repository for T110II server. This issue is tracked with BITS091699
  • YUM 7.3.1 :Inventory of Power supply firmware shows invalid version string on PER820 with RHEL5.9x86_64. This issue is tracked with BITS110762
  • YUM 7.3.1 does not support Intel I350 Gigabit Network card update
  • For PERC 6E/I firmwares, if the current installed version and the repository version differ only by '.' and '-', update window will display them as applicable. Please ignore. For example, current version (6.3.3.0002) and the repository version (6.3.3-0002) mean they are having the same versions.
  • You cannot upgrade Server Administrator 7.3 A00 to A01
  • Upgrading to Server Administrator 7.3 using YUM will not install some of the new RPMs, if you have installed the Server Administrator version 7.2 or earlier using the installer scripts.
    • To support the new granular install feature on Linux, the RPMs have been restructured. It is recommended to use the same upgrade option that was used for installation. For Example, Install script to install script or YUM to YUM.
    • Mixing the install options will not install all the new RPMs and will cause loss of functionality. This case is only an exception that occurs when there is a mixing of the install methods and impacts only the installation of new RPMS.
    • If the install methods are not mixed, then all the RPM installs go through without any issues in either of the methods.
  • While doing "yum upgrade" if you find "broken package error", please run the command "yum remove OpenIPMI*" and then do "yum upgrade"
  • When you perform Intel NIC updates using YUM GUI , sometimes duplicate ports gets listed on the GUI and the updates will fail.
  • When you try to update the power supply firmware, you will see failures
  • When your system has multiple network cards that needs update, please use YUM CLI instead of YUM GUI. The updates via GUI is time consuming because of repeated attempts though updates will be successful)
Personal tools
Distributions